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How To.....
Install Quantum GIS from Offline Packages
Installing Quantum GIS
1. Navigate using Windows explorer to the folder containing “osgeo4w-setup.exe.” Double click
this program to launch the setup program
2. Select “Advanced Install.” Click Next
3. Select “Install from Local Directory.” Click Next
4. Choose a Root Directory for the program to be installed to. Click Next
N.B. If you do not know what to put here, leave it as the default value
5. Set the “Local Package Directory” to the directory that you opened the “osgeo4w-Setup.exe”
from. Click Next
6. In the “Select Packages” dialog, make sure that each of the “Command Line Utilities,” “Desktop”
and “Libs” sub components are set to a version number, and not “skip”
N.B. To see the sub components, click on the “+” sign to the left of the Component names
7. Click Next. QuantumGIS and the required components will install. At the end of the installation
procedure, it will ask if you would like to place an icon on the desktop or in the start menu.
Leave both boxes checked.

Basic Controls (Lecture 1)
Use Basic Controls
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New /Open/Save Project - creates, retrieves or saves a map document
Pan, Zoom In/Out/Extent/Square/Last/Next - controls how much of the data is displayed at one time.
Zoom controls will change the map scale.
Identify - quickly gives you information about the feature you click on
Select - selects one of more polygons (click and drag)
Open Attribute Table - allows you to inspect the underlying data contained in a feature
Measure Distance/Area - interactively allows the user to measure straight line distance and areas

Introduction to GIS Data (Lecture 2)
Create a new Shapefile
1. Click on the new shapefile button or navigate to Layer > New Vector Layer
2. Choose the type of layer; Point, Line or Polygon
3. Identify the attributes that you want to add in this new layer by setting the name, width and
precision and clicking “Add to attributes list”
N.B. if you make a mistake you can highlight the offending attribute and click on “Remove
selected attribute”
4. Save the new layer by selecting “OK.” This will create the layer and load it into the Table of
contents
5. Edit the layer using the “Digitizing” or “Advanced Digitizing” toolbar (See How To below for
more information)

Collecting and Creating Data (Lecture 3)
GeoReference an Image
1. Navigate to Plugins > Geo Referencer
2. Browse to the raster file that you want to reference
3. Define coordinate system (we used WGS84)
4. Click on a point in the now loaded image
N.B. zoom in on the image to pick the exact place you are trying to reference
5. Enter in the desired X,Y location that that point in the image represents on the ground
Or, choose to get the coordinates from the map canvas
6. After selecting three or more locations for transfer click on “Create and Load Layer”. The image
will be referenced.
N.B. Be careful that you are using the correct coordinate system or the image will not display
correctly and the image could be skewed
Edit a Layer
1. Load the layer into Quantum GIS
2. Ensure that the “Digitizing” toolbar is open
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3. Highlight the layer you wish to edit on the table of contents
4. Click on the pencil icon to start an edit session. Depending on the layer type this will enable
different tool. For instance, point data has options to create new points, where the polygon and
line layers will have different
N.B. To end a line segment or a polygon, right mouse click
5. To end the edit session, click on the pencil icon again. A prompt will ask you to save, cancel or
discard. If you are happy with the edits, click “save”

GPS Integration (Lecture 4)
Import GPS Data using GPS Babel
1. Start GPSBabelGUI.exe
2. Select the Device checkbox
3. Select the COM port that your GPS device is using
N.B. Often this will be COM3 or COM6
4. Select the output format you wish
5. Specify the output location
6. Check the Waypoints and Tracks boxes (if you wish to have tracks as well)
7. Click on “Lets GO” button. Wait patiently for the program to finish running
N.B. This may take some time if there is a lot of data in you GPS Unit
Editing KML in Notepad
1. Open the KML File in notepad
2. Use Ctrl+H or Edit > Replace to bring up the Replace dialog
3. In the “Find What” box, put in the exactly text you wish to replace
N.B. the is likely “ACTIVE LOG” or something like that
4. In the “Replace With” box, put in the text you want to replace the found text with
N.B. this is probably something like “Mike’s Journey”
5. Save and reload the KML file in Google Earth

Attribute Data (Lecture 5)
Adding XY text files to Quantum
1. Navigate to Plugins > Delimited Text > Add a Delimited Text Layer
2. Select the layer via the “Browse” button
3. Select a name for the new layer
4. The “Delimiter” is the character that separates the data fields
N.B. in all of our examples, this has been a comma (,)
5. Once the layer and delimiter have been set, the field that contains the X value and Y values can
be set
6. If everything looks right, click on “OK”
N.B. always use “Plain Text” and not “Regular Expression”
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Joining DBF Tables to Quantum
1. Add data to Excel and format so that it will enter Quantum GIS correctly
N.B. we looked at how word can be helpful as an intermediary step in formatting
2. Navigate to Insert > Name > Define. Select the data in the table to include
3. Save the data as a DBF file
N.B. this cannot be done in word 2007 or higher
4. In QuantumGIS navigate to Tools > Data Management Tools > Join Attributes
5. Select the target vector layer you want to join the data to, browse for the DBF table and choose
the output shapefile
6. Define the join field in the input vector layer and the DBF table
7. Click OK. The resultant shape file should have matched all the pairs with new data

Thematic Mapping (Lecture 6)
Thematically Display Data
1. Right click on a layer with thematic data and select “Properties” to open the properties dialog
2. Click on the Symbology tab, and change the Legend type drop box to “Graduated Symbol”
3. Select a classification field to visualize, a mode for classifying the data and a number of classes
4. Click “Classify“ to generate the classes for your data
5. Click on “Apply” or “OK” to confirm your data classification and apply it to your data
Apply Labels to Data
1. Rick click on a layer and go to “Properties”
2. Navigate to the Labels Tab and check on the “Display Labels” box
3. Choose the field in the data to label in the “Field containing label” drop box
4. Click on “apply” or “OK” to confirm your label field and apply it to your data

Vector GeoProcessing (Lecture 7)
Complete a Basic Search of Data Tables
1. Right click on the layer that you wish to search and select “Open Attribute Table”
2. In the “Look For” text box, enter the name that you wish to find
3. In the “in” drop box, select the field in the table you would like to search
4. Click search
N.B. The search works on exact terms, if you miss-spell what you are searching for the program
will not find the data
Select Features by Location
1. Navigate to Tools > Research Tools > Select By Location
2. Enter the layer you want to search for and the layer that will be searched in for intersections
3. Choose the current selection modifier
4. Click “Ok”

Selected How To’s Page: 8
Gather Basic Statistics
1. Navigate to Tools > Analysis Tools > Basic Statistics
2. Choose the layer and target field that you wish to calculate statistics for
3. Click on “Ok” and the statistics will appear in the window
4. Click “Close” to leave the dialog
Clip Features
1. Navigate to Tools > GeoProcessing Tools > Clip
2. Select the layer that you want to clip data from the “Input Vector Layer” drop box
3. Select the layer that you want to define the clip based on in the “Clip Layer” drop box
4. Choose and output shapefile for the clipped features by clicking on “Browse”
5. Click “Ok” to clip the features
Buffer Features
1. Navigate to Tools >Geoprocessing Tools > Buffer
2. Select an input feature to buffer around
N.B. This can be a point , line or polygon
3. Choose a buffer distance in map units
N.B. If you are using WGS84 as your coordinate system the number will be in degrees
4. Click “Browse” to select an output file for your buffers
5. Click “OK” to buffer around your features
Generate Random Stratified Sample Locations
1. Navigate to Tools > Research Tools > Random Points
2. Select an input polygonal layer to stratify the random points by
3. Select the “Use this number of points” under the “Stratified Sampling Design (individual
Polygons) “ section
4. Click “Browse” to select an output file for your random points
5. Click “OK” to generate the randomly stratified points inside the polygonal layer
Approximate an Inverse Data Weighted (IDW) Surface
1. Navigate to Plugins > Interpolation > Interpolation
2. Select an input vector layer to generate the surface based on
N.B. The input layer can be point, line or polygon. It is recommended to only use point or line
data however
3. Select the data field that the interpolation will be based upon and click “Add”
N.B. The attribute may not be a text layer. It is also recommended to use only one attribute layer
at a time
4. Choose “Inverse Data Weighted” from the “Interpolation method” drop box
5. Set the spatial extent of the newly interpolated layer either using the Y and X Min and Max
fields, or by clicking on the “Set to current extent” button
6. Click “Browse” to select an output file for your interpolated surface
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7. Click “Ok” to generate the surface
N.B. You can change the distance coefficient by clicking on the wrench icon next to the
Interpolation method drop box

Raster GeoProcessing (Lecture 8)
Generate an aspect map
1. Open a Digital Elevation Model (DEM) Raster file in Quantum
2. Navigate to Plugins > Raster Based Terrain Analysis > Raster Based Terrain Analysis
3. Select “Aspect “ from the “Analysis” drop box
4. Select the DEM from the “Input layer” drop box
5. Click on the “...” button to specify an output layer name
6. Select “GeoTIFF” in the “Output Format” drop box
N.B. While GeoTIFF is the mostly commonly used format (and the default option), other formats
may be used for importing data into other programs
7. Check the “Add result to project” box
8. Click on “OK” to complete the analysis
Visualizing a Hillshade model from Aspect Output
1. Generate and load a Aspect model from a DEM in Quantum GIS
2. Open the properties dialog by right clicking on the aspect layer and selecting “Properties”
3. Select the “Symbology” tab in the properties dialog
4. Set the “Color Map” drop box to “Grayscale”
5. Select the “Use Standard Deviation” option and input “2” in the text box
6. In the “Contrast Enhancement” section, select “Stretch To MinMax” in the “Current” drop box
7. Click on ‘OK” or “Apply” to confirm your changes and see the hillshade model
Add 3D Information to Satellite Imagery
1. Load an aspect raster into Quantum GIS and transform it into a Hillshade model
2. Load a tile of Satellite imagery onto Quantum GIS. Ensure that the imagery is below the
Hillshade model in the Table of Contents
3. Open the properties dialog by right clicking on the aspect layer and selecting “Properties”
8. Select the “Transparency” tab in the properties dialog
4. In the “Global transparency” section, Drag the slider control to about 60%
5. Click on ‘OK” or “Apply” to confirm your changes and see the 3D relief on the satellite imagery
N.B. you may have to adjust the transparency from 60% to a higher or lower value depending on
the ratio of hillshade to satellite imagery that you want. The point is to be able to see both the
underlying imagery and the 3d relief at the same time

Grass GIS for Quantum (Lecture 8.5)
Create a new Grass mapset
1. Navigate to Plugins > GRASS > New Mapset or click on the “New Mapset” icon on the grass
toolbar
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2. Click “Browse” to select a location for the grass database and click “Next”
N.B. this location may already be set, if so it is recommended not to change this
3. Either choose a location that has already been set up in the “Select Location” drop box, or enter
in a new location name in the “Create new location” text box. Click “Next”
4. If you have chosen a new location you will need to navigate to and define a projection for the
grass location, Do so and click “Next”
N.B. In this training we used WGS84
5. If you have chosen a new location you will need to definite the default Grass region by inputting
a value for N, S, W and E. Click “Next” when these values are set.
N.B. These values are in the map coordinates that you set in your projection (previous step). If
you are using WGS84, this will be in degrees of latitude and longitude.
6. Give your mapset a name in the “New Mapset” text box. Click “Next”
N.B. use a descriptive name with no spaces. For instance I might make the mapset name
“AmaroData” if the mapset contained all of my data for Amaro
7. Review the Database location, the Location name and the Mapset name. If any are incorrect use
the “Back” button to change these. If everything looks to be in order, click “finish”
Unlock a GRASS Mapset
1. If you try to open a mapset after Quantum GIS has failed you will receive a “Mapset Already in
Use” message.
2. To remove this message, navigate to the file location of the GRASS Database using Windows
Explorer
N.B. The Windows explorer is the file browser in windows and is accessible by clicking on “My
Computer”
3. Find the mapset folder and the file “.gislock”
4. Delete this file and reload the mapset in GRASS for Quantum
Change the Current Grass Region
1. Navigate to Plugins > GRASS > Edit current GRASS region or click on the “Edit Current GRASS
Region” button on the grass toolbar
2. Enter in the desired changes to the region in the “Grass Region Settings” dialog.
3. Click “OK” to accept the changes
N.B. The GRASS region is very important for any raster based analysis. The region defines the
extent that all raster analysis operates to
Use the Grass Toolbox
1. Navigate to Plugins > GRASS > Open GRASS Tools or click on the “Open GRASS Tools” button on
the GRASS toolbar
2. From the modules tab, select the procedure that you would like to perform
N.B. A common procedure we used is the “import raster” procedure, located under File > Import
> Import Raster > r.in.gdal.qgis
3. In the tab that opens (marked as “->”) Enter in the “options” requirements. These will change
based on the analysis you wish to complete
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4. Click on “Run.” You will see the output tab display the result of the actions
N.B. If there was an error in the procedure (usually from incorrect input) the output tab will
explain the problem and usually how to fix it.
5. Click on “View Output” to add the new layer to the map display (where available)
N.B. If you do not know how to use a procedure, check the “manual” tab
Import Data into a GRASS Mapset
1. Open the a Grass Mapset
2. Open the Grass tools dialog and navigate to File > Import > Import Raster > r.in.gdal.qgis
Open the Grass Tools dialog and navigate to File > Import > Import Vector > v.in.ogr.qgis
3. Select a data layer open in the Table of Contents that you wish to import as the “input” drop
box
4. Enter a name for the imported layer in the “Output Vector/Raster” text box
5. Click on “Run.” You will see the output tab display the result of the actions
6. Click on “View Output” to add the imported layer to the map display
Export Grass Data to Shapefile
1. Open Grass Tools and run a clumping or thinning procedure on the data if it is vector
information you are going to export (Thinning for lines, clumping for polygons) via navigating to
Raster > Transform features > r.clump / r.thin
2. Export the Raster via navigating to File > Export > Export Raster > r.out.gdal
Export the Vector via navigating to File > Export > Export Vector > v.out.ogr
3. Select the input map and gdal/ogr format you want to output to
N.B. the output format it usually GeoTIFF/Shapefile, but may change depending on your input
requirements of the program you plan to use the files within
4. Select an output filename for the new raster/vector by clicking on “...”
5. Click on “run” to perform the conversion
Generate Contour Lines from DEM
1. Open the GRASS Tools Dialog and navigate to Raster > Surface management > Generate Vector
Contour Lines
2. Select the input DEM and input an “Increment between contour lines” in meters
3. Name the output vector map
4. Click on “Run.” You will see the output tab display the result of the actions
N.B. If there was an error in the procedure (usually from incorrect input) the output tab will
explain the problem and usually how to fix it.
5. Click on “View Output” to add the new layer to the map display (where available)
Reclassify a Raster Layer
1. Open the GRASS Tools Dialog and navigate to Raster > Change category values and labels >
r.reclass – Reclass raster using reclassification rules
2. Select an input raster to reclassify, browse for the reclassification rules using the “...” button and
specify a name for the output raster map

Selected How To’s Page: 12
N.B. to see how to create a classification rule set, see the powerpoint notes or select the
“Manual” tab
3. Click on “Run.” You will see the output tab display the result of the actions
N.B. If there was an error in the procedure (usually from incorrect input) the output tab will
explain the problem and usually how to fix it.
4. Click on “View Output” to add the new layer to the map display (where available)
5. Convert the reclassified raster to a vector file to display the data thematically
Create Watershed Basins
1. Open the GRASS Tools Dialog and navigate to Raster > Hydrologic Modelling > Watershed
Analysis
2. Select an input DEM, the minimum size of exterior watershed basin and a name for the output
raster map of the basins
N.B. the minimum exterior size of watershed basin will be in meters (I think. I find the somewhere
in the range of 5000 – 50,000 is best)
3. Click on “Run.” You will see the output tab display the result of the actions
4. Convert the resultant raster to a vector file to display the data thematically
N.B. make sure that when you process the DEM layer, you set the extents of your grass region
carefully. If these are not set right, the processing will increase exponentially and create a large
headache when clipping the result to a manageable level of information
Perform Map algebra
1. Create distance raster maps using buffers, and converting to raster
N.B. the GRASS Buffer tool is much better than the fTools in Quantum. The GRASS Buffer
command is available through Raster > Spatial Analysis > Buffer > r.buffer
2. Open the GRASS Tools Dialog and navigate to Raster > Spatial Analysis > Map algebra >
r.mapcalc – Graphical raster map Calculator
3. Visually place raster maps and calculations in the equation window
N.B. The equation canvas will become larger as element get close to the edge.
4. Click on “Run.” You will see the output tab display the result of the actions
N.B. Save the equation by clicking on the disk icon, this is in case you wish to know what
equation you entered previously (if you are as forgetful as me, this is very handy) or in case you
need to modify or re-run the model again

Layouts (Lecture 9)
Open the Print Composer and Add a Map
1. Navigate to File > Print Composer or click on the “Print Composer” icon
2. Click on the “Add a new map” icon
N.B. This icon looks a bit like a unrolled scroll with a green plus (+) icon in the lower right hand
corner
3. Click and drag the mouse across the screen to add a map to the layout
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Add a Graphic or Chart to the Layout
1. To make a chart from your data, open the DBF file (in the shapefile’s directory) in Excel
2. Create the graph and take a screen capture using the “PrtSc” key on your keyboard
3. Open “MS Paint” from the Windows “Start Menu”
4. Paste the screen capture into the Paint window using Edit > Paste or by using the keystroke
“ctrl+v.” Crop and edit the graphic as necessary and save the image as a JPEG file
5. In the Quantum GIS Print Composer click the “Add Image” button and then click on your
Print Canvas. This will add a blank box with blue corners to the canvas
6. In the right hand side of the print composer click on the “Add...” button to find the JPEG (or
other format) that you wish to insert, such as the Chart made in Excel or another image or
logo
N.B. Do not save the DBF file you have been messing around with, this just leads to trouble
later on

